    <!doctype html>
<html lang="en-GB">
    <head>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="https://gmpg.org/xfn/11">

        <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='The stunning Prodrive P25 has been revealed before its debut';
</script>

	<!-- This site is optimized with the Yoast SEO plugin v19.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>The stunning Prodrive P25 has been revealed before its debut</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CBarlow%3Aital%2Cwght%400%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B0%2C800%3B0%2C900%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700%3B1%2C800%7CBarlow%20Semi%20Condensed%3Aital%2Cwght%400%2C300%3B0%2C400%3B0%2C500%3B0%2C600%3B0%2C700%3B1%2C300%3B1%2C400%3B1%2C500%3B1%2C600%3B1%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /></noscript>
	<meta name="description" content="despite of We knew P25 was comingAnd, that it would look like a two-door Impreza and be so powerful and expensive, we&#039;ll admit we&#039;re drowning in the" />
	<link rel="canonical" href="https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/" />
	<meta property="og:locale" content="en_GB" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="The stunning Prodrive P25 has been revealed before its debut" />
	<meta property="og:description" content="despite of We knew P25 was comingAnd, that it would look like a two-door Impreza and be so powerful and expensive, we&#039;ll admit we&#039;re drowning in the" />
	<meta property="og:url" content="https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/" />
	<meta property="og:site_name" content="Great Indian Mutiny" />
	<meta property="article:published_time" content="2022-06-20T16:50:50+00:00" />
	<meta property="og:image" content="https://www.mutiny.in/wp-content/uploads/2022/06/The-stunning-Prodrive-P25-has-been-revealed-before-its-debut.jpg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jack Kimmons" />
	<meta name="twitter:label2" content="Estimated reading time" />
	<meta name="twitter:data2" content="4 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.mutiny.in/#organization","name":"Great Indian Mutiny","url":"https://www.mutiny.in/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://www.mutiny.in/#/schema/logo/image/","url":"https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo.png","contentUrl":"https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo.png","width":453,"height":188,"caption":"Great Indian Mutiny"},"image":{"@id":"https://www.mutiny.in/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://www.mutiny.in/#website","url":"https://www.mutiny.in/","name":"Great Indian Mutiny","description":"Complete IndianNews World","publisher":{"@id":"https://www.mutiny.in/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.mutiny.in/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-GB"},{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#primaryimage","url":"https://www.mutiny.in/wp-content/uploads/2022/06/The-stunning-Prodrive-P25-has-been-revealed-before-its-debut.jpg","contentUrl":"https://www.mutiny.in/wp-content/uploads/2022/06/The-stunning-Prodrive-P25-has-been-revealed-before-its-debut.jpg","width":1440,"height":960},{"@type":"WebPage","@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#webpage","url":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/","name":"The stunning Prodrive P25 has been revealed before its debut","isPartOf":{"@id":"https://www.mutiny.in/#website"},"primaryImageOfPage":{"@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#primaryimage"},"datePublished":"2022-06-20T16:50:50+00:00","dateModified":"2022-06-20T16:50:50+00:00","description":"despite of We knew P25 was comingAnd, that it would look like a two-door Impreza and be so powerful and expensive, we'll admit we're drowning in the","breadcrumb":{"@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#breadcrumb"},"inLanguage":"en-GB","potentialAction":[{"@type":"ReadAction","target":["https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/"]}]},{"@type":"BreadcrumbList","@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"The stunning Prodrive P25 has been revealed before its debut"}]},{"@type":"Article","@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#article","isPartOf":{"@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#webpage"},"author":{"@id":"https://www.mutiny.in/#/schema/person/e9a92c11fdf33181e92ebce0e072c69d"},"headline":"The stunning Prodrive P25 has been revealed before its debut","datePublished":"2022-06-20T16:50:50+00:00","dateModified":"2022-06-20T16:50:50+00:00","mainEntityOfPage":{"@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#webpage"},"wordCount":732,"commentCount":0,"publisher":{"@id":"https://www.mutiny.in/#organization"},"image":{"@id":"https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#primaryimage"},"thumbnailUrl":"https://www.mutiny.in/wp-content/uploads/2022/06/The-stunning-Prodrive-P25-has-been-revealed-before-its-debut.jpg","articleSection":["Tech"],"inLanguage":"en-GB","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#respond"]}]},{"@type":"Person","@id":"https://www.mutiny.in/#/schema/person/e9a92c11fdf33181e92ebce0e072c69d","name":"Jack Kimmons","image":{"@type":"ImageObject","inLanguage":"en-GB","@id":"https://www.mutiny.in/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/9840a206663e9ee1d2f5f25a30ab11c0?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/9840a206663e9ee1d2f5f25a30ab11c0?s=96&d=mm&r=g","caption":"Jack Kimmons"},"description":"\"Communicator. Music aficionado. Certified bacon trailblazer. Travel advocate. Subtly charming social media fanatic.\""}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Great Indian Mutiny &raquo; Feed" href="https://www.mutiny.in/feed/" />
<link rel="alternate" type="application/rss+xml" title="Great Indian Mutiny &raquo; Comments Feed" href="https://www.mutiny.in/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Great Indian Mutiny &raquo; The stunning Prodrive P25 has been revealed before its debut Comments Feed" href="https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.mutiny.in/wp-includes/css/dist/block-library/style.min.css?ver=5.9' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.mutiny.in/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.mutiny.in/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://www.mutiny.in/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.mutiny.in/wp-content/themes/newsever-pro/assets/font-awesome/css/font-awesome.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.mutiny.in/wp-content/themes/newsever-pro/assets/bootstrap/css/bootstrap.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css-css'  href='https://www.mutiny.in/wp-content/themes/newsever-pro/assets/slick/css/slick.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css'  href='https://www.mutiny.in/wp-content/themes/newsever-pro/assets/sidr/css/jquery.sidr.dark.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://www.mutiny.in/wp-content/themes/newsever-pro/assets/magnific-popup/magnific-popup.css?ver=5.9' type='text/css' media='all' />

<link rel='stylesheet' id='newsever-style-css'  href='https://www.mutiny.in/wp-content/themes/newsever-pro/style.css?ver=5.9' type='text/css' media='all' />
<style id='newsever-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.mutiny.in/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.mutiny.in/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js' defer></script>

<script type='text/javascript' id='jquery-js-after'>window.addEventListener('DOMContentLoaded', function() {
jQuery(document).ready(function() {
	jQuery(".1a5f3472f2e4fdf37d220713031330c2").click(function() {
		jQuery.post(
			"https://www.mutiny.in/wp-admin/admin-ajax.php", {
				"action": "quick_adsense_onpost_ad_click",
				"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
				"quick_adsense_nonce": "def92f013d",
			}, function(response) { }
		);
	});
});
});</script>

<link rel="https://api.w.org/" href="https://www.mutiny.in/wp-json/" /><link rel="alternate" type="application/json" href="https://www.mutiny.in/wp-json/wp/v2/posts/11492" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mutiny.in/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mutiny.in/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9" />
<link rel='shortlink' href='https://www.mutiny.in/?p=11492' />
<link rel="alternate" type="application/json+oembed" href="https://www.mutiny.in/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mutiny.in%2Fthe-stunning-prodrive-p25-has-been-revealed-before-its-debut%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.mutiny.in/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mutiny.in%2Fthe-stunning-prodrive-p25-has-been-revealed-before-its-debut%2F&#038;format=xml" />
<link rel="preconnect" href="https://cdnjs.cloudflare.com">

<style type='text/css'>img#wpstats{display:none}</style>
	<link rel="pingback" href="https://www.mutiny.in/xmlrpc.php">        <style type="text/css">
                        body .header-style1 .top-header.data-bg:before,
            body .header-style1 .main-header.data-bg:before {
                background: rgba(0, 0, 0, 0);
            }

                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            
            

        </style>
        <style type="text/css">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</style><link rel="icon" href="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Favicon-150x92.png" sizes="32x32" />
<link rel="icon" href="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Favicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Favicon.png" />
<meta name="msapplication-TileImage" content="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Favicon.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>    </head>

<body data-rsssl=1 class="post-template-default single single-post postid-11492 single-format-standard wp-custom-logo wp-embed-responsive aft-default-mode aft-hide-comment-count-in-list aft-hide-minutes-read-in-list aft-hide-date-author-in-list default-content-layout content-with-single-sidebar align-content-left">

<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>



        <header id="masthead" class="header-style1 header-layout-side">

                <div class="top-header">
        <div class="container-wrapper">
            <div class="top-bar-flex">
                <div class="top-bar-left col-66">

                    
                    <div class="date-bar-left">
                                                    <span class="topbar-date">
                                        June 20, 2022                                    </span>

                                                                    </div>
                                            <div class="af-secondary-menu">
                            <div class="container-wrapper">
                                
                            </div>
                        </div>
                                        </div>

                <div class="top-bar-right col-3">
  						<span class="aft-small-social-menu">
  							  						</span>
                </div>
            </div>
        </div>

    </div>
<div class="main-header  "
     data-background="">
    <div class="container-wrapper">
        <div class="af-container-row af-flex-container">

            
            <div class="col-1 float-l pad">
                <div class="logo-brand">
                    <div class="site-branding">
                        <a href="https://www.mutiny.in/" class="custom-logo-link" rel="home"><img width="453" height="188" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20453%20188'%3E%3C/svg%3E" class="custom-logo" alt="Great Indian Mutiny" data-lazy-srcset="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo.png 453w, https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo-300x125.png 300w" data-lazy-sizes="(max-width: 453px) 100vw, 453px" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo.png" /><noscript><img width="453" height="188" src="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo.png" class="custom-logo" alt="Great Indian Mutiny" srcset="https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo.png 453w, https://www.mutiny.in/wp-content/uploads/2021/06/Great-Indian-Mutiny-Logo-300x125.png 300w" sizes="(max-width: 453px) 100vw, 453px" /></noscript></a>                            <p class="site-title font-family-1">
                                <a href="https://www.mutiny.in/"
                                   rel="home">Great Indian Mutiny</a>
                            </p>
                        
                                                    <p class="site-description">Complete IndianNews World</p>
                                            </div>
                </div>
            </div>

            
        </div>
    </div>

</div>
<div class="exclusive-news">
                    <div class="banner-exclusive-posts-wrapper clearfix">

                
                <div class="container-wrapper">
                    <div class="exclusive-posts">
                        <div class="exclusive-now primary-color">
                                                            <span class="exclusive-news-title"> 
                                    Exclusive                                </span>
                                                        <div class="exclusive-now-txt-animation-wrap">
                                <span class="fancy-spinner">
                                    <div class="ring"></div>
                                    <div class="ring"></div>
                                    <div class="dot"></div>
                                </span>
                                <span class="exclusive-texts-wrapper">
                                                                    <span class="exclusive-news-subtitle af-exclusive-animation">
                                        <span>Breaking News</span>
                                    </span>
                                                                </span>
                            </div>
                        </div>
                        <div class="exclusive-slides" dir="ltr">
                                                        <div class='marquee aft-flash-slide left' data-speed='80000'
                                 data-gap='0' data-duplicated='true' data-direction="left">
                                                                    <a href="https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/">
                                        
                                        
                                        <span class="circle-marq">
                                                                            </span>

                                        The stunning Prodrive P25 has been revealed before its debut                                    </a>
                                                                    <a href="https://www.mutiny.in/monsoon-floods-in-bangladesh-and-india-affect-millions/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Monsoon floods in Bangladesh and India affect millions" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/Monsoon-floods-in-Bangladesh-and-India-affect-millions-150x150.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/Monsoon-floods-in-Bangladesh-and-India-affect-millions-150x150.jpg"
                                                 alt="Monsoon floods in Bangladesh and India affect millions"></noscript>
                                                                            </span>

                                        Monsoon floods in Bangladesh and India affect millions                                    </a>
                                                                    <a href="https://www.mutiny.in/at-least-7-insurgents-were-killed-in-various-operations-in-indian-kashmir/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img fifu-featured="1" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="" title="" data-lazy-src="https://www.swissinfo.ch/resource/image/45945846/landscape_ratio16x9/1920/1080/caa0764b3418d762daa605efa298d327/00A4B15C884C1E8D3D2F927F0EACC09B/fallback-1200x630-swi.jpg"><noscript><img fifu-featured="1" src="https://www.swissinfo.ch/resource/image/45945846/landscape_ratio16x9/1920/1080/caa0764b3418d762daa605efa298d327/00A4B15C884C1E8D3D2F927F0EACC09B/fallback-1200x630-swi.jpg"
                                                 alt="" title=""></noscript>
                                                                            </span>

                                        At least 7 insurgents were killed in various operations in Indian Kashmir                                    </a>
                                                                    <a href="https://www.mutiny.in/sbf-and-alameda-intervene-to-prevent-cryptographic-breakdown-contagion/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="SBF and Alameda Intervene to Prevent Cryptographic Breakdown Contagion" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/SBF-and-Alameda-Intervene-to-Prevent-Cryptographic-Breakdown-Contagion-150x150.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/SBF-and-Alameda-Intervene-to-Prevent-Cryptographic-Breakdown-Contagion-150x150.jpg"
                                                 alt="SBF and Alameda Intervene to Prevent Cryptographic Breakdown Contagion"></noscript>
                                                                            </span>

                                        SBF and Alameda Intervene to Prevent Cryptographic Breakdown Contagion                                    </a>
                                                                    <a href="https://www.mutiny.in/dixie-carter-reveals-his-surprising-impact-originals-co-star-at-slammiversary/">
                                        
                                        
                                        <span class="circle-marq">
                                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E"
                                                 alt="Dixie Carter reveals his surprising Impact Originals co-star at Slammiversary" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/Dixie-Carter-reveals-his-surprising-Impact-Originals-co-star-at-Slammiversary-150x150.png"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/Dixie-Carter-reveals-his-surprising-Impact-Originals-co-star-at-Slammiversary-150x150.png"
                                                 alt="Dixie Carter reveals his surprising Impact Originals co-star at Slammiversary"></noscript>
                                                                            </span>

                                        Dixie Carter reveals his surprising Impact Originals co-star at Slammiversary                                    </a>
                                                            </div>
                                                        </div>
                    </div>
                </div>
            </div>
            <!-- Excluive line END -->
        </div>

            <div class="header-menu-part">
                <div id="main-navigation-bar" class="bottom-bar">
                    <div class="navigation-section-wrapper">
                        <div class="container-wrapper">
                            <div class="header-middle-part">
                                <div class="navigation-container">
                                    <nav class="main-navigation clearfix">
                                                                                    <span class="aft-home-icon">
                                                                                        <a href="https://www.mutiny.in">
                                            <i class="fa fa-home"
                                               aria-hidden="true"></i>
                                        </a>
                                    </span>
                                                                                <span class="toggle-menu" aria-controls="primary-menu"
                                              aria-expanded="false">
                                                <a href="javascript:void(0)" class="aft-void-menu">
                                        <span class="screen-reader-text">
                                            Primary Menu                                        </span>
                                        <i class="ham"></i>
                                                </a>
                                    </span>
                                        <div class="menu main-menu menu-desktop show-menu-border"><ul id="primary-menu" class="menu"><li id="menu-item-530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.mutiny.in">Home</a></li>
<li id="menu-item-531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.mutiny.in/top-news/">Top News</a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.mutiny.in/world/">World</a></li>
<li id="menu-item-533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.mutiny.in/economy/">Economy</a></li>
<li id="menu-item-534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://www.mutiny.in/science/">science</a></li>
<li id="menu-item-535" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-535"><a href="https://www.mutiny.in/tech/">Tech</a></li>
<li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://www.mutiny.in/sport/">sport</a></li>
<li id="menu-item-537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.mutiny.in/entertainment/">entertainment</a></li>
<li id="menu-item-2920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2920"><a href="https://www.mutiny.in/contact-form/">Contact Form</a></li>
</ul></div>                                    </nav>
                                </div>
                            </div>
                            <div class="header-right-part">
                                <div class="af-search-wrap">
                                    <div class="search-overlay">
                                        <a href="#" title="Search" class="search-icon">
                                            <i class="fa fa-search"></i>
                                        </a>
                                        <div class="af-search-form">
                                            <form role="search" method="get" class="search-form" action="https://www.mutiny.in/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                                        </div>
                                    </div>
                                </div>
                                <div class="popular-tag-custom-link">
                                    
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>

        </header>

        <!-- end slider-section -->
        
            <div class="container-wrapper">
                    </div>
    
    
        <header class="entry-header pos-rel aft-no-featured-image">
            <div class="container-wrapper ">
                <div class="read-details af-container-block-wrapper">

                    


                    
                    <div class="newsever-entry-header-details-wrap float-l col-1">
                            <div class="entry-header-details  af-have-yt-link">
                    <div class="read-categories">
                <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>
            </div>
        
        <h1 class="entry-title">The stunning Prodrive P25 has been revealed before its debut</h1>        <div class="post-meta-share-wrapper">
            <div class="post-meta-detail">
                                    <span class="min-read-post-format">
                                                                            </span>
                <span class="entry-meta">
                                        
            <span class="item-metadata posts-author byline">
                    <i class="fa fa-pencil-square-o"></i>
            <a href="https://www.mutiny.in/author/frosty-dirac/">
                Jack Kimmons            </a>
        </span>
                                            </span>
                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                June 20, 2022            </span>
                        <span class="min-read">4 min read</span>            </div>
                    </div>
        
    </div>
                        </div>


                </div>

            </div>


            
        </header><!-- .entry-header -->

        <!-- end slider-section -->
            
    <div id="content" class="container-wrapper ">
    <div class="af-container-block-wrapper clearfix">
        <div id="primary" class="content-area ">
            <main id="main" class="site-main ">
                                    <article id="post-11492" class="post-11492 post type-post status-publish format-standard hentry category-tech">

                        
                        
                                <div class="entry-content-wrap read-single">
                                                                        

        <div class="entry-content read-details">
            <div id="">
<div style="transform:translate(0px, 0px) scale(1)" class="🏎14QaoP">
<div class="🏎2WXlom 🏎qcIEFN 🏎2PaxXZ"><img alt="" src="" srcset="" class="🏎1OycdU 🏎3Hr5iv"/></div>
<p><noscript></p>
<div class="🏎2WXlom 🏎qcIEFN 🏎2PaxXZ"><img alt="" src="https://www.mutiny.in/wp-content/uploads/2022/06/The-stunning-Prodrive-P25-has-been-revealed-before-its-debut.jpg" class="🏎1OycdU 🏎3Hr5iv"/></div>
<p></noscript></div>
<div class="🏎2PaxXZ">
<p>despite of <a target="_blank" href="https://www.pistonheads.com/news/ph-japanesecars/new-prodrive-p25-reimagines-impreza-22b/45732" rel="noopener">We knew P25 was coming</a>And, that it would look like a two-door Impreza and be so powerful and expensive, we&#8217;ll admit we&#8217;re drowning in the bottom line.  We certainly haven&#8217;t seen it in the flesh yet &#8211; the lids closed at the Festival of Speed ​​this Thursday &#8211; but there certainly can be no argument that the P25 looks to work.  After launching the original WRC Impreza 25 years ago, Prodrive says it has &#8220;reimagined what this car would have been today&#8221;.  Good job guys. </p>
</div>
<div class="🏎2PaxXZ">
<p>And of course things are getting better.  Those modified body panels?  Carbon composite, a lot.  Trunk, hood, roof, sills, door mirrors, front and rear quarters, rear spoiler and fenders are WRC-style.  Peter Stevens, who designed the WRC version back in the day, is responsible for the new look (those rear brackets alone make us laugh funny) and Prodrive&#8217;s experience putting it back together means the P25 weighs less than 1,200kg, despite retaining the monocoque from Steel WRX. </p>
</div>
<div class="🏎2PaxXZ">
<p>In this updated lightweight mix, the company has introduced Subaru&#8217;s latest 2.5-liter model, though it has been completely redesigned with custom interior components, including new cylinder liners, pistons, connecting rods and valve train with variable cam timing.  Oh, and there&#8217;s a Garrett motorsport turbo engine as well with an intercooler and airbox, as well as an Akrapovic titanium and stainless steel exhaust system.  All said it gives 400 horsepower and 443 pound-feet of torque, and we&#8217;ll go ahead and say that the P25 probably looks as good as it looks. </p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.mutiny.in/square-enix-details-current-issues-and-the-future-of-the-new-switch-racer-chocobo-gp/" target="_blank" rel="dofollow" class="u79fd8203e9c4b9cf808461409dba33cc"><!-- INLINE RELATED POSTS 1/3 //--><style> .u79fd8203e9c4b9cf808461409dba33cc { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:inherit; border:0!important; border-left:4px solid inherit!important; text-decoration:none; } .u79fd8203e9c4b9cf808461409dba33cc:active, .u79fd8203e9c4b9cf808461409dba33cc:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .u79fd8203e9c4b9cf808461409dba33cc { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .u79fd8203e9c4b9cf808461409dba33cc .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .u79fd8203e9c4b9cf808461409dba33cc .postTitle { color:inherit; text-decoration: underline!important; font-size: 16px; } .u79fd8203e9c4b9cf808461409dba33cc:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">See also</span>&nbsp; <span class="postTitle">Square Enix details current issues and the future of the new Switch Racer Chocobo GP</span></div></a></div></div>
<div style="transform:translate(0px, 0px) scale(1)" class="🏎14QaoP">
<div class="🏎2WXlom 🏎qcIEFN 🏎2PaxXZ 🏎32NtmE"><img alt="" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="🏎1OycdU 🏎3Hr5iv 🏎2lg8qm" data-lazy-src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; viewBox=&quot;0 0 4 3&quot;%3E%3C/svg%3E"/><noscript><img alt="" src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; viewBox=&quot;0 0 4 3&quot;%3E%3C/svg%3E" class="🏎1OycdU 🏎3Hr5iv 🏎2lg8qm"/></noscript></div>
<p><noscript></p>
<div class="🏎2WXlom 🏎qcIEFN 🏎2PaxXZ"><img alt="" src="https://www.mutiny.in/wp-content/uploads/2022/06/1655743850_483_The-stunning-Prodrive-P25-has-been-revealed-before-its-debut.jpg" class="🏎1OycdU 🏎3Hr5iv"/></div>
<p></noscript></div>
<div class="🏎2PaxXZ">
<p>It will also go seriously.  Prodrive estimates it will hit 62 mph in under 3.5 seconds, thanks in part to a six-speed sequential box with helical cut-off gears, but also because it gets WRC-style Launch Control that combines the throttle and clutch.  In the floor-mounted pedal box to automatically shift the vehicle through 1st, 2nd and 3rd gear.  Just imagine it out of the limelight. </p>
</div>
<div class="🏎2PaxXZ">
<p>Power is transmitted to all four wheels via an adjustable active center differential and limited-slip differential front and rear (which gives you an idea of ​​how the P25 handles).  Prodrive has kept the McPherson struts, but says it used machined aluminum struts that can be tuned to get the optimum geometry for the car&#8217;s wider 1,770mm track.  New Bilstein dampers can be adjusted for compression and rebound while the springs and anti-roll bars are optimized for tarmac handling.  You also get AP Racing brakes and cool 19-inch Prodrive rims. </p>
</div>
<div class="🏎2PaxXZ">
<p>We haven&#8217;t seen the interior yet, although the dashboard features a full-width, multi-page display including a data logger, and there&#8217;s the option of a &#8220;partial&#8221; safety cage and racing seats.  The company clearly expects owners to take the car on the track (would you have to, right?) and it has satisfied daily use of the track with its &#8220;various throttle response and engine performance maps, including lag-prevention adjustment.&#8221;  And if you&#8217;re thinking of &#8220;Lordy,&#8221; there&#8217;s also a WRC &#8220;fly-off&#8221; hydraulic manual brake, which automatically disengages the center differential to remove drive to the rear wheels.  Which means the P25 is custom made to accommodate all kinds of silliness. </p>
<div style="clear:both; margin-top:0em; margin-bottom:1em;"><a href="https://www.mutiny.in/netflix-users-were-surprised-to-use-the-highly-rated-playstation-games-remaster-for-free/" target="_blank" rel="dofollow" class="uc08620eafd8c152266314cd98daea8d6"><!-- INLINE RELATED POSTS 2/3 //--><style> .uc08620eafd8c152266314cd98daea8d6 { padding:0px; margin: 0; padding-top:1em!important; padding-bottom:1em!important; width:100%; display: block; font-weight:bold; background-color:inherit; border:0!important; border-left:4px solid inherit!important; text-decoration:none; } .uc08620eafd8c152266314cd98daea8d6:active, .uc08620eafd8c152266314cd98daea8d6:hover { opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; text-decoration:none; } .uc08620eafd8c152266314cd98daea8d6 { transition: background-color 250ms; webkit-transition: background-color 250ms; opacity: 1; transition: opacity 250ms; webkit-transition: opacity 250ms; } .uc08620eafd8c152266314cd98daea8d6 .ctaText { font-weight:bold; color:inherit; text-decoration:none; font-size: 16px; } .uc08620eafd8c152266314cd98daea8d6 .postTitle { color:inherit; text-decoration: underline!important; font-size: 16px; } .uc08620eafd8c152266314cd98daea8d6:hover .postTitle { text-decoration: underline!important; } </style><div style="padding-left:1em; padding-right:1em;"><span class="ctaText">See also</span>&nbsp; <span class="postTitle">Netflix users were surprised to use the highly-rated PlayStation game's Remaster for free</span></div></a></div></div>
<div style="transform:translate(0px, 0px) scale(1)" class="🏎14QaoP">
<div class="🏎2WXlom 🏎qcIEFN 🏎2PaxXZ 🏎32NtmE"><img alt="" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" class="🏎1OycdU 🏎3Hr5iv 🏎2lg8qm" data-lazy-src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; viewBox=&quot;0 0 4 3&quot;%3E%3C/svg%3E"/><noscript><img alt="" src="data:image/svg+xml,%3Csvg xmlns=&quot;http://www.w3.org/2000/svg&quot; viewBox=&quot;0 0 4 3&quot;%3E%3C/svg%3E" class="🏎1OycdU 🏎3Hr5iv 🏎2lg8qm"/></noscript></div>
<p><noscript></p>
<div class="🏎2WXlom 🏎qcIEFN 🏎2PaxXZ"><img alt="" src="https://www.mutiny.in/wp-content/uploads/2022/06/1655743850_479_The-stunning-Prodrive-P25-has-been-revealed-before-its-debut.jpg" class="🏎1OycdU 🏎3Hr5iv"/></div>
<p></noscript></div>
<div class="🏎2PaxXZ">
<p>That&#8217;s a good thing because, as might be expected, the P25 doesn&#8217;t come cheap.  For one thing only there will be 25 of them (obvs) and for another &#8211; if the above description doesn&#8217;t mention it to you &#8211; it&#8217;s as close to a rally car for the road as you would ever go get.  Accordingly, Prodrive will charge £460,000 plus VAT for each example.  Big money, sure — but if this stuff doesn&#8217;t disappear from Banbury shelves like hot cakes, we&#8217;ll be eating our PH hats.  In fact, with Goodwood imminent and a run up the hill in the scheduled development car, we expect they&#8217;ll all be gone by the end of the week. </p>
</div>
<div class="🏎2PaxXZ">
<p>Prodrive Chairman David Richards said: “The iconic blue Subarus brings back memories of an extraordinary era of WRC and it was the Impreza 22B that brought this race car performance to the road.  By redesigning this vehicle using the latest technology and materials, the Prodrive P25 honors its roots and there won&#8217;t be much else that can match its performance on the open road.  So I think we&#8217;ve fulfilled our vision of creating our modern interpretation of the most iconic Subaru Impreza ever.” Deliveries are set to begin for the lucky few later this year.</p>
</div>
<div class="🏎1Vsh8L 🏎2PaxXZ" data-type-id="image-gallery">
<div class="image-gallery" aria-live="polite">
<div class="image-gallery-content bottom">
<div class="image-gallery-slide-wrapper bottom"><button class="🏎TIAaKF 🏎ZHGHUM 🏎2d-8tM 🏎qBFaEd" type="button" tabindex="-1"><span class="🏎J-oSPj 🏎1G6Kdp 🏎29rIJp"><svg xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false" data-prefix="far" data-icon="chevron-left" class="svg-inline--fa fa-chevron-left fa-2x " role="img" viewbox="0 0 320 512"><path fill="currentColor" d="M206.7 464.6l-183.1-191.1C18.22 267.1 16 261.1 16 256s2.219-11.97 6.688-16.59l183.1-191.1c9.152-9.594 24.34-9.906 33.9-.7187c9.625 9.125 9.938 24.37 .7187 33.91L73.24 256l168 175.4c9.219 9.5 8.906 24.78-.7187 33.91C231 474.5 215.8 474.2 206.7 464.6z"/></svg></span><span class="🏎32xmjA">Scroll left</span></button><button class="🏎TIAaKF 🏎ZHGHUM 🏎2d-8tM 🏎3GpyPt" type="button" tabindex="-1"><span class="🏎J-oSPj 🏎1G6Kdp 🏎29rIJp"><svg xmlns="http://www.w3.org/2000/svg" aria-hidden="true" focusable="false" data-prefix="far" data-icon="chevron-right" class="svg-inline--fa fa-chevron-right fa-2x " role="img" viewbox="0 0 320 512"><path fill="currentColor" d="M113.3 47.41l183.1 191.1c4.469 4.625 6.688 10.62 6.688 16.59s-2.219 11.97-6.688 16.59l-183.1 191.1c-9.152 9.594-24.34 9.906-33.9 .7187c-9.625-9.125-9.938-24.38-.7187-33.91l168-175.4L78.71 80.6c-9.219-9.5-8.906-24.78 .7187-33.91C88.99 37.5 104.2 37.82 113.3 47.41z"/></svg></span><span class="🏎32xmjA">right of movement</span></button></p>
<p><span class="image-gallery-index-current">1</span><span class="image-gallery-index-separator">    / </span><span class="image-gallery-index-total">3</span></p>
</div>
</div>
</div>
</div>
</div>
<!--CusAds0-->
<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" width="100"  height="100" alt="" itemprop="image" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2021/08/ddb653f1-cb7a-4b1b-b8cf-c1fc80d6ae67.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2021/08/ddb653f1-cb7a-4b1b-b8cf-c1fc80d6ae67.jpg" width="100"  height="100" alt="" itemprop="image"></noscript></div><div class="saboxplugin-authorname"><a href="https://www.mutiny.in/author/frosty-dirac/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Jack Kimmons</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>&#8220;Communicator. Music aficionado. Certified bacon trailblazer. Travel advocate. Subtly charming social media fanatic.&#8221;</p>
</div></div><div class="clearfix"></div></div></div>                            <div class="post-item-metadata entry-meta">
                                    </div>
                        
	<nav class="navigation post-navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.mutiny.in/hack-twentieth-anniversary-series-trailer/" rel="prev"><span class="em-post-navigation">Previous</span> .hack Twentieth Anniversary Series Trailer</a></div></div>
	</nav>                    </div><!-- .entry-content -->
                                </div>

                        <div class="aft-comment-related-wrap">
                            
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.mutiny.in/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='11492' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="177e49b3fa" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="20"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

                            
<div class="promotionspace enable-promotionspace">

        <div class="af-reated-posts grid-layout">
                            <h4 class="widget-title header-after1">
                            <span class="header-after">
                                More Stories                            </span>
                </h4>
                        <div class="af-container-row clearfix">
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://www.mutiny.in/wp-content/uploads/2022/06/hack-Twentieth-Anniversary-Series-Trailer-720x475.jpg">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/hack-Twentieth-Anniversary-Series-Trailer-720x475.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/hack-Twentieth-Anniversary-Series-Trailer-720x475.jpg"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                </div>
                                <a href="https://www.mutiny.in/hack-twentieth-anniversary-series-trailer/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://www.mutiny.in/hack-twentieth-anniversary-series-trailer/">.hack Twentieth Anniversary Series Trailer</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    June 20, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://www.mutiny.in/author/frosty-dirac/">
                            Jack Kimmons                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://www.mutiny.in/wp-content/uploads/2022/06/Jack-and-Daxter-is-being-transferred-from-PS2-to-PC-720x475.jpg">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/Jack-and-Daxter-is-being-transferred-from-PS2-to-PC-720x475.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/Jack-and-Daxter-is-being-transferred-from-PS2-to-PC-720x475.jpg"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                </div>
                                <a href="https://www.mutiny.in/jack-and-daxter-is-being-transferred-from-ps2-to-pc-by-fans/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://www.mutiny.in/jack-and-daxter-is-being-transferred-from-ps2-to-pc-by-fans/">Jack and Daxter is being &#8220;transferred&#8221; from PS2 to PC by fans</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    June 20, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://www.mutiny.in/author/frosty-dirac/">
                            Jack Kimmons                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"data-background="https://www.mutiny.in/wp-content/uploads/2022/06/The-PS5-Slim-which-is-only-2cm-high-was-made-720x475.jpg">
                                <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/The-PS5-Slim-which-is-only-2cm-high-was-made-720x475.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/The-PS5-Slim-which-is-only-2cm-high-was-made-720x475.jpg"></noscript>
                                <div class="min-read-post-format">
                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                </div>
                                <a href="https://www.mutiny.in/the-ps5-slim-which-is-only-2cm-high-was-made-by-a-youtuber/"></a>
                            </div>
                            <div class="read-details color-tp-pad no-color-pad">
                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://www.mutiny.in/the-ps5-slim-which-is-only-2cm-high-was-made-by-a-youtuber/">The PS5 Slim, which is only 2cm high, was made by a YouTuber</a>
                                    </h4>
                                </div>
                                <div class="entry-meta">
                                    
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    June 19, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://www.mutiny.in/author/frosty-dirac/">
                            Jack Kimmons                        </a>
                    </span>
                
        </span>
                                        </div>

                            </div>
                        </div>
                    </div>
                            </div>

    </div>
</div>


                        </div>


                    </article>
                
            </main><!-- #main -->
        </div><!-- #primary -->
        



<div id="secondary" class="sidebar-area aft-sticky-sidebar">
    <div class="theiaStickySidebar">
        <aside class="widget-area color-pad">
            <div id="nav_menu-2" class="widget newsever-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span class="header-after">Navigate</span></h2><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://www.mutiny.in">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://www.mutiny.in/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://www.mutiny.in/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://www.mutiny.in/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-534"><a href="https://www.mutiny.in/science/">science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-535"><a href="https://www.mutiny.in/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://www.mutiny.in/sport/">sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://www.mutiny.in/entertainment/">entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2920"><a href="https://www.mutiny.in/contact-form/">Contact Form</a></li>
</ul></div></div><div id="nav_menu-3" class="widget newsever-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span class="header-after">Pages</span></h2><div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="menu"><li id="menu-item-498" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-498"><a href="https://www.mutiny.in/">Home</a></li>
<li id="menu-item-2923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2923"><a href="https://www.mutiny.in/about-us/">About Us</a></li>
<li id="menu-item-2922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2922"><a href="https://www.mutiny.in/dmca/">DMCA</a></li>
<li id="menu-item-2921" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2921"><a href="https://www.mutiny.in/editorial-policy/">Editorial Policy</a></li>
<li id="menu-item-2924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2924"><a href="https://www.mutiny.in/contact-form/">Contact Form</a></li>
</ul></div></div>        </aside>
    </div>
</div>    </div>


</div>

<div class="af-main-banner-latest-posts grid-layout">
    <div class="container-wrapper">
    <div class="af-container-block-wrapper pad-20">
            <div class="widget-title-section">
                                    <h4 class="widget-title header-after1">
                            <span class="header-after">
                                You may have missed                            </span>
                    </h4>
                
            </div>
            <div class="af-container-row clearfix">
                                            <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="">
                                        <img src="">
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">4 min read</span>                            </span>
                                        </div>
                                        <a href="https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/tech/" alt="View all posts in Tech"> 
                                 Tech
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://www.mutiny.in/the-stunning-prodrive-p25-has-been-revealed-before-its-debut/">The stunning Prodrive P25 has been revealed before its debut</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    June 20, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://www.mutiny.in/author/frosty-dirac/">
                            Jack Kimmons                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://www.mutiny.in/wp-content/uploads/2022/06/Monsoon-floods-in-Bangladesh-and-India-affect-millions-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/Monsoon-floods-in-Bangladesh-and-India-affect-millions-720x475.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/Monsoon-floods-in-Bangladesh-and-India-affect-millions-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://www.mutiny.in/monsoon-floods-in-bangladesh-and-india-affect-millions/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/world/" alt="View all posts in World"> 
                                 World
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://www.mutiny.in/monsoon-floods-in-bangladesh-and-india-affect-millions/">Monsoon floods in Bangladesh and India affect millions</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    June 20, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://www.mutiny.in/author/aarav/">
                            Louie Daves                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://www.swissinfo.ch/resource/image/45945846/landscape_ratio16x9/1920/1080/caa0764b3418d762daa605efa298d327/00A4B15C884C1E8D3D2F927F0EACC09B/fallback-1200x630-swi.jpg">
                                        <img fifu-featured="1" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.swissinfo.ch/resource/image/45945846/landscape_ratio16x9/1920/1080/caa0764b3418d762daa605efa298d327/00A4B15C884C1E8D3D2F927F0EACC09B/fallback-1200x630-swi.jpg"><noscript><img fifu-featured="1" src="https://www.swissinfo.ch/resource/image/45945846/landscape_ratio16x9/1920/1080/caa0764b3418d762daa605efa298d327/00A4B15C884C1E8D3D2F927F0EACC09B/fallback-1200x630-swi.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">2 min read</span>                            </span>
                                        </div>
                                        <a href="https://www.mutiny.in/at-least-7-insurgents-were-killed-in-various-operations-in-indian-kashmir/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/top-news/" alt="View all posts in Top News"> 
                                 Top News
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://www.mutiny.in/at-least-7-insurgents-were-killed-in-various-operations-in-indian-kashmir/">At least 7 insurgents were killed in various operations in Indian Kashmir</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    June 20, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://www.mutiny.in/author/aditya/">
                            Byron Rodgers                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                    <div class="col-4 pad float-l" data-mh="you-may-have-missed">
                                <div class="read-single color-pad">
                                    <div class="data-bg read-img pos-rel read-bg-img"
                                         data-background="https://www.mutiny.in/wp-content/uploads/2022/06/SBF-and-Alameda-Intervene-to-Prevent-Cryptographic-Breakdown-Contagion-720x475.jpg">
                                        <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://www.mutiny.in/wp-content/uploads/2022/06/SBF-and-Alameda-Intervene-to-Prevent-Cryptographic-Breakdown-Contagion-720x475.jpg"><noscript><img src="https://www.mutiny.in/wp-content/uploads/2022/06/SBF-and-Alameda-Intervene-to-Prevent-Cryptographic-Breakdown-Contagion-720x475.jpg"></noscript>
                                        <div class="min-read-post-format">
                                                                                        <span class="min-read-item">
                                <span class="min-read">3 min read</span>                            </span>
                                        </div>
                                        <a href="https://www.mutiny.in/sbf-and-alameda-intervene-to-prevent-cryptographic-breakdown-contagion/"></a>
                                    </div>
                                    <div class="read-details color-tp-pad">

                                        <div class="read-categories">
                                            <ul class="cat-links"><li class="meta-category">
                             <a class="newsever-categories category-color-1" href="https://www.mutiny.in/economy/" alt="View all posts in Economy"> 
                                 Economy
                             </a>
                        </li></ul>                                        </div>
                                        <div class="read-title">
                                            <h4>
                                                <a href="https://www.mutiny.in/sbf-and-alameda-intervene-to-prevent-cryptographic-breakdown-contagion/">SBF and Alameda Intervene to Prevent Cryptographic Breakdown Contagion</a>
                                            </h4>
                                        </div>
                                        <div class="entry-meta">
                                            
            <span class="author-links">

                            <span class="item-metadata posts-date">
                <i class="fa fa-clock-o"></i>
                    June 20, 2022            </span>
                            
                    <span class="item-metadata posts-author byline">
                        <i class="fa fa-pencil-square-o"></i>
                        <a href="https://www.mutiny.in/author/vihaan/">
                            Iris Pearce                        </a>
                    </span>
                
        </span>
                                                </div>
                                    </div>
                                </div>
                            </div>
                                                        </div>
    </div>
    </div>
</div>

<footer class="site-footer">
        
                <div class="site-info">
        <div class="container-wrapper">
            <div class="af-container-row">
                <div class="col-1 color-pad">
                                                                Copyright &copy; All rights reserved.                                                                                    <span class="sep"> | </span>
                        <a href="https://afthemes.com/products/newsever">Newsever</a> by AF themes.                                    </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>













<script type='text/javascript' id='newsever-pagination-js-js-extra'>
/* <![CDATA[ */
var AFurl = {"nonce":"5780afc927","ajaxurl":"https:\/\/www.mutiny.in\/wp-admin\/admin-ajax.php","dir":"left"};
/* ]]> */
</script>



<script type='text/javascript' id='fifu-image-js-js-extra'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"","fifu_woo_lbox_enabled":"1","fifu_woo_zoom":"inline","fifu_is_product":"","fifu_is_flatsome_active":"","fifu_rest_url":"https:\/\/www.mutiny.in\/wp-json\/","fifu_nonce":"b5f32ef9cb"};
/* ]]> */
</script>


<script src='https://stats.wp.com/e-202225.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9.1',blog:'22391668',post:'11492',tz:'5.5',srv:'www.mutiny.in'} ]);
	_stq.push([ 'clickTrackerInit', '22391668', '11492' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.mutiny.in/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
<script src="https://www.mutiny.in/wp-content/cache/min/1/424693a737d9af24003ea52a5acd0f83.js" data-minify="1" defer></script></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1655743854 -->